Issue with MotherDuck Resources

Incident Report for Retool

Resolved

MotherDuck is fully operational again. We identified and fixed a caching issue that required us to temporarily disable the integration. Access has been restored as of May 11, 2026. We apologize for the disruption.
Posted May 12, 2026 - 03:07 UTC

Investigating

We're investigating an issue with our MotherDuck integration for Cloud orgs
Posted May 11, 2026 - 23:50 UTC
This incident affected: Web Application and APIs and Resource Queries.