Workflows with custom npm libraries failing to install

Incident Report for Retool

Resolved

This incident has been resolved. Self-hosted customers should update to 3.300.28-stable or 3.334.12-stable for the fix.
Posted May 08, 2026 - 22:33 UTC

Monitoring

A fix has been deployed to Retool Cloud. Self-hosted customers should upgrade to 3.300.28-stable or 3.334.12-stable, which has the fix. We are monitoring to confirm full resolution.
Posted May 08, 2026 - 18:15 UTC

Identified

We are investigating an issue where workflows using custom npm libraries are failing to execute. This affects both Retool Cloud and self-hosted customers.

A fix has been identified and is currently being deployed to Cloud. Self-hosted patch releases are in progress.
Posted May 08, 2026 - 17:03 UTC
This incident affected: Workflows.