Some queries and page loads experiencing degraded performance
Incident Report for Retool
Resolved
We've deployed a fix and systems appear to be operational.
Posted Nov 25, 2020 - 17:33 UTC
Investigating
We are currently investigating this issue.
Posted Nov 25, 2020 - 16:36 UTC
This incident affected: Web Application and APIs.