Retool Mobile on Android v3.191.0 facing crashes on load

Incident Report for Retool

Resolved

We have resolved the issue that was causing Retool Mobile v3.191.0 to crash on launch for Android users. The patched version (v3.191.1) has been reviewed and is now available in the Google Play Store for users who had updated to the 3.191.0 version.

If you were impacted by this issue please update to the latest version of Retool Mobile via the Play Store to restore full functionality.
If problems persist after updating, please contact our support team for assistance.

Users who never updated to the 3.191.0 version should see the 3.191.1 within the next hour or so, and for the time being may see 1.83.0 on their device still, this is the same build and should not be an issue.
Posted Apr 22, 2025 - 10:40 UTC

Monitoring

We’ve moved this incident to Monitoring as no new users should be impacted and the issue has been resolved in the patched build (v3.191.1). However, the update is still pending approval in the Google Play Store.

Until the Play Store version becomes available, we recommend impacted users continue using the temporary workaround of directly downloading the APK provided in our previous update:

👉 https://retool-mobile-releases-public.s3.us-west-2.amazonaws.com/3079.apk

This manual installation will allow you to resume use of Retool Mobile on affected Android devices
Posted Apr 22, 2025 - 06:46 UTC

Update

We’ve identified the root cause of the crash affecting Retool Mobile v3.191.0 on Android and have submitted a patched version (v3.191.1) to the Google Play Store for review that will auto release when approved. Based on typical review timelines, we expect the update to be approved and available for download within the next few hours.

In the meantime, for users currently blocked by the crash, we’re providing a temporary workaround: you can manually install the patched version by downloading the APK directly from the link below. Please note that this version has not yet been verified by the Play Store, so you will see a warning during installation. Follow on-screen instructions to allow the installation if you choose to proceed, and agree to update the current app.

👉 https://retool-mobile-releases-public.s3.us-west-2.amazonaws.com/3079.apk
Posted Apr 22, 2025 - 06:25 UTC

Identified

We’ve identified an issue in the latest version of Retool Mobile (v3.191.0) for Android that is causing the app to crash immediately upon launch. The rollout was promptly halted after being downloaded by a limited number of users and will no longer be downloaded by new users.

Our engineering team is actively investigating the root cause and working on fast tracking a recovery release for devices already impacted.

We’ll provide our next update by 11:30pm Pacific Time, or sooner if more information becomes available.
Posted Apr 22, 2025 - 05:50 UTC
This incident affected: Web Application and APIs.