Errors running generic JDBC resource type queries

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 19:06 UTC

Identified

Some customers are seeing generic JDBC resource type queries fail with an error referencing LZ4 compression. Connection tests still pass, so the error appears only when running a query or loading a resource schema.

We have identified the cause and are working on a fix.
Posted Sep 01, 2026 - 15:31 UTC
This incident affected: Resource Queries.