Intermittent failures with Google Sheets, MySQL, and PostgreSQL integrations

Incident Report for Retool

Resolved

We've confirmed that the resources affected are operational and have resolved this incident.
Posted Feb 25, 2026 - 17:54 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 25, 2026 - 05:52 UTC

Monitoring

We’re experiencing elevated error rates on our Google Sheets, MySQL, and PostgreSQL integrations.
The root cause has been identified and is under active monitoring by our engineering team.

All query operations continue to function as expected. We’ll keep you posted with any new developments.

Thank you for your patience.
Posted Feb 25, 2026 - 05:08 UTC
This incident affected: Workflows and Resource Queries.