Workflows Stuck in Pending State

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 05:52 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2026 - 23:08 UTC

Monitoring

The fix has been deployed, and we're monitoring the results. Workflows are still degraded but recovering.
Posted Jul 30, 2026 - 21:20 UTC

Identified

We've identified the issue and are working on a fix.
Posted Jul 30, 2026 - 20:45 UTC

Investigating

We are investigating an issue with Retool Workflows being stuck in a pending state. There is also an uptick in 429 rate limit responses for start triggers
Posted Jul 30, 2026 - 20:22 UTC
This incident affected: Workflows and Retool-managed Temporal (via Temporal.io).