Retool Resources: Slack files.upload API Deprecation

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 23:46 UTC

Identified

Slack is ending support for their files.upload API on March 11, 2025.

You will now need to use the files.getUploadURLExternal and files.completeUploadExternal APIs to continue using upload functionality. Slack's changelog provides more information on this change as well as migration steps: https://api.slack-gov.com/changelog/2024-04-a-better-way-to-upload-files-is-here-to-stay

Our team is aware of this change and is working to update our Slack integration as quickly as possible. In the meantime, you should be able to use a REST Query to utilize the new APIs. https://docs.retool.com/queries/guides/api/rest

We apologize for any inconvenience and will keep you posted.
Posted Mar 11, 2025 - 01:07 UTC
This incident affected: Resource Queries.