Intermittent App Navigation Issues on Cloud

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 21:08 UTC

Identified

Unfortunately this issue has not been fully resolved as previously indicated, and we are continuing to work on a fix. We apologise for the continued disruption.
Posted Mar 17, 2026 - 17:36 UTC
This incident affected: Classic web app.