[Retool Cloud] PostgreSQL and REST API Resource Queries Intermittently Failing

Incident Report for Retool

Resolved

Following the fix we are seeing error rates of the affected services return to normal. With that in mind, we are considering this issue resolved.
Posted Apr 16, 2026 - 18:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2026 - 17:36 UTC

Identified

We have identified the potential root cause of this issue and are implementing a fix
Posted Apr 16, 2026 - 17:01 UTC

Investigating

We are currently investigating an issue causing PostgreSQL and REST API queries to fail. This also affects users' ability to use RetoolDB.
Posted Apr 16, 2026 - 15:49 UTC
This incident affected: Resource Queries and RetoolDB.