Retool Mobile apps cannot be opened in the in-browser preview

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 19:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 16:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 04, 2026 - 15:45 UTC

Investigating

We are investigating reports that Retool Mobile apps fail to load when opened in a web browser (the in-browser "View"/user-mode preview and the editor preview button). Editing mobile apps and running them in the native iOS/Android Retool Mobile apps are unaffected.
Posted Jun 04, 2026 - 15:13 UTC
This incident affected: Web Application and APIs.