[Retool Cloud] Google Sheets Integration Intermittently Failing with "Premature Close" Errors

Incident Report for Retool

Resolved

We are closing this incident as it has been identified as part of a larger issue. Please follow: [Retool Cloud] PostgreSQL and REST API Resource Queries Intermittently Failing, for the latest updates and resolution progress.
Posted Apr 16, 2026 - 17:33 UTC

Investigating

We are investigating an issue where Google Sheets resources are intermittently failing with a "premature close" error. This is affecting a subset of users on Retool Cloud. Our team is actively investigating the root cause and working on a mitigation.
Posted Apr 16, 2026 - 15:31 UTC
This incident affected: Resource Queries.