Snowflake Rejecting OAuth Requests With prompt Parameter

Incident Report for Retool

Resolved

The issue has been fixed on Retool Cloud and all systems are operating normally. Self-hosted customers can remove the `prompt` parameter as a workaround until the patch is available.
Posted Dec 18, 2025 - 23:46 UTC

Identified

We have identified an issue where OAuth requests to Snowflake with any value being passed via the prompt parameter are being rejected. We are actively working on implementing a fix.

In the meantime, the current workaround is to remove the prompt parameter entirely from your OAuth requests to Snowflake.
Posted Dec 18, 2025 - 19:53 UTC
This incident affected: Resource Queries.