App page loads returning 521 errors and failing to load for some users
Incident Report for Retool
Resolved
We have confirmed our workaround has resolved this issue and are continuing to engage Cloudflare support for a root cause on their end.
Posted Sep 21, 2021 - 18:00 UTC
Monitoring
We've disabled the cloudflare proxy for this region which looks to have resolved the issue for the moment while we continue to investigate. We believe the root cause is cloudflare’s central US servers facing an issue talking to our Washington state servers, but are awaiting word from cloudflare support. This DNS change may take some time to propagate depending on your service provider, but all reporting users have confirmed that service is restored for them now.
Posted Sep 21, 2021 - 17:45 UTC
Update
We've purged our cloudflare cache which seems to have resolved the issue for some users, and are continuing to investigate any ongoing reports. The issue currently looks to be isolated towards the midwest United States and Central America.
Posted Sep 21, 2021 - 17:29 UTC
Investigating
We are currently investigating reports of apps failing to load while returning console errors loading CSS chunks
Posted Sep 21, 2021 - 17:10 UTC
This incident affected: Web Application and APIs.