Retool MCP connection errors

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 22:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2026 - 19:13 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 14, 2026 - 16:26 UTC

Investigating

We're investigating an issue causing some users to experience errors when connecting to Retool's MCP server. Some connections may fail. We're working on a fix and will provide updates as we have them.
Posted Sep 14, 2026 - 16:07 UTC
This incident affected: Platform APIs.