Performance degradation

Incident Report for Retool

Resolved

This issue has been resolved
Posted Oct 28, 2024 - 15:13 UTC

Investigating

We are currently observing performance issues around loading apps in Retool Cloud.
Posted Oct 28, 2024 - 14:06 UTC