Downstream Email Service Provider Outage

Incident Report for Retool

Resolved

Provider has fully recovered.
Posted May 14, 2025 - 22:56 UTC

Identified

Platform features relying on email sending (invites, password reset etc) will be degraded until the outage is resolved

Data connectors using the Retool Email resource type are NOT affected at this time. They should continue to be fully functional.
Posted May 14, 2025 - 18:50 UTC
This incident affected: Email Server.