Backend API high latency
Incident Report for Retool
Resolved
This incident has been resolved.
Posted May 23, 2022 - 15:56 UTC
Monitoring
We have applied a fix and are currently monitoring a high latency spike from this morning.
Posted May 23, 2022 - 15:15 UTC
This incident affected: Web Application and APIs and Infrastructure.